Помогите решить задачу по информатике в паскале!Напишите программу, которая считывает...

0 голосов
22 просмотров
Помогите решить задачу по информатике в паскале!
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны!
Пример:
Ввод: 179
Вывод:
The next number for the number 179 is 180.
The previous number for the number 179 is 178.

Информатика (121 баллов) | 22 просмотров
Дано ответов: 2
0 голосов

Var
x: real;

begin
read(x);
writeln('The next number for the number ', x, ' is ', x + 1);
writeln('The previous number for the number ', x, ' is ', x - 1);
end.

0 голосов
var
  y: real;

begin
  read(y);
  writeln(String.Format('The next number for the number {0} is {1}.', y, y + 1)); 
  writeln(String.Format('The previous number for the number {0} is {1}.', y, y - 1));
end.
(16.9k баллов)