4. Написать программу, которая вводит массив из N целых чисел и выводит ** экран сам...

0 голосов
78 просмотров

4. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:
а) 1 3 4 -2
б) 0 1 -2 10 11 12 -10 -3
в) 1 1 1 1 -1 -1 -1 -1


Информатика (40 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
const n=10;
var a: array [1..n] of integer;
i,sum: integer;
begin
sum:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
end;
writeln('массив: ');
for i:=1 to n do begin
sum:=sum+a[i];
write(a[i],' ');
end;
writeln;
writeln('сумма: ',sum);
end.

(149k баллов)
0

очень помог)