Напишите программу для решения квадратного уравнения вида ax^2+bx+c, где a не равно 0....

0 голосов
55 просмотров

Напишите программу для решения квадратного уравнения вида ax^2+bx+c, где a не равно 0.
Примечание:
Если ваше условие выполняется и необходимо выполнение более одного действия, используйте для них конструкцию begin end, сохраняя оформление(сдвиг вправо).
Пример: if a>b then begin
a:=b-1;
Writeln('A=',a);
end
else writeln ('B=',b);

Примечание: Во всех задачах предусмотрите очистку экрана при каждом запуске программы и задержку экрана, чтобы не нужно было нажимать Alt+F5. А такое вначале на экране должна отображаться суть программы, не забывайте про грамотные диалоговые моменты.


Информатика (335 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Var a,b,c:real; 
begin 
readln(a); 
readln(b); 
readln(c); 
if (b*b-4*a*c)>=0 then writeln('deistvitelnie korni est!') else writeln('deistvitelnih korney net'); 
if (b*b-(4*a*c))>0 then begin writeln('2 kornya'); writeln('x1= ',(-b-sqrt(b*b-4*a*c))/(2*a)); writeln('x2= ',(-b+sqrt(b*b-4*a*c))/(2*a)) end; 
if (b*b-(4*a*c))=0 then begin writeln('1 koren'); writeln('x= ',(-b+sqrt(b*b-4*a*c))/(2*a)) end; 
end.

(381 баллов)