Задание очень срочное!!! Нужно до 22.00 05.11.2015!!! Написать программу, которая...

0 голосов
35 просмотров

Задание очень срочное!!! Нужно до 22.00 05.11.2015!!!
Написать программу, которая заменяет цифру числа названием этой цифры.
Например, заменить число 4563 на строку четыре пять шесть три.
ПАСКАЛЬ!!!


Информатика (97 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n: integer;
  answer: string;
 
begin
  read(n);
  while n > 0 do {Пока есть цифры добавляем последнюю цифру числа к ответу и отбрасываем ее}
  begin
    case n mod 10 of
      0: answer := 'ноль ' + answer;
      1: answer := 'один ' + answer;
      2: answer := 'два ' + answer;
      3: answer := 'три ' + answer;
      4: answer := 'четыре ' + answer;
      5: answer := 'пять ' + answer;
      6: answer := 'шесть ' + answer;
      7: answer := 'семь ' + answer;
      8: answer := 'восемь ' + answer;
      9: answer := 'девять ' + answer;
    end;
    n := n div 10;
  end;
  writeln(answer);
end.

(13.3k баллов)