Написать программу полностью. СРОЧНО (Паскаль) "Найти индексы тех элементов массива, у...

0 голосов
29 просмотров

Написать программу полностью. СРОЧНО (Паскаль)
"Найти индексы тех элементов массива, у которых значение больше, чем значение предыдущего элемента"


Информатика (16 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var a:array [1..100] of integer;
k,n,i:integer;
begin
clrscr;
write('Введите количество элементов массива=');
readln(n);
randomize;
for i:=1 to n do
a[i]:=random(45)-20;
writeln('Исходный массив');
for i:=1 to n do
 write(a[i]:6);
writeln;
for i:=1 to n-1 do
 if a[i+1]>a[i] then 
  writeln('Индексы: ',i:3);
writeln;
readln;
end.

(840 баллов)
0

это точно правильно?

0

Ну если Вы вообще не понимаете суть задания и алгоритма, который я Вам скинул, то попробуйте разобраться с каждой строкой сами. Учите языки программирования - это интересно