Паскаль Составьте программу, которая заменяет в строке S слово "мама" ** слово "папа"...

0 голосов
75 просмотров

Паскаль
Составьте программу, которая заменяет в строке S слово "мама" на слово "папа" Пример ввода: Мама играет с ребенком. Пример вывода: Папа играет с ребенком.


Информатика (16 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

Var
i:integer;
s:string;
begin
readln(s);
i := Pos('мама', s); 
if i > 0 then
 begin  
Delete(s, i, 4);  
Insert('папа', s, i); 
end;
writeln(s);
end.

(1.4k баллов)