1.Составить программу табуляции функции f(x) ** отрезке [a;b] шагом h.Параметры a,b и h...

0 голосов
68 просмотров

1.Составить программу табуляции функции f(x) на отрезке [a;b] шагом h.Параметры a,b и h вводит пользователь с клавиатуры.
f(x) = x/cosx.

2.Найти значение выражения,используя цикл с параметром.Предусмотрен ввод с клавиатуры значений всех переменных.
Дано натуральное n вычислить значение выражения:
y = ( 1 - 1/2) * ( 1 - 1/4) ·...· (1-1/2n).


Информатика (152 баллов) | 68 просмотров
0

Паскаль? С++ ?

0

да

0

PASCAL

Дан 1 ответ
0 голосов
Правильный ответ

Var
A,B,H:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('H = ');ReadLn(H);
Repeat
WriteLn(A/Cos(A));
A:=A+H;
Until A>B;
End.


Var
N:integer;
Y:real;
Begin
Y:=1;
Write('N = ');ReadLn(N);
For N:= 1 to N do
    Y:=Y*(1-1/(N*2));
Write('Y = ',Y);
End.

(34.0k баллов)
0

БООООООООООООЖЕЕЕ!Спасибо!!!!!!!!!