СРОЧНО!!!! Написать программу, определяющую по длинам сторон А,В и С является ли...

0 голосов
56 просмотров

СРОЧНО!!!!
Написать программу, определяющую по длинам сторон А,В и С является ли треугольник равнобедренным.


Информатика (21 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

//Pascal
var
 a,b,c:integer;

begin
  readln(a,b,c);
  if ((a=b) AND (a<>c) ) OR ((a=c) AND (a<>b)) OR ((b=c) AND (b<>a)) then
   writeln('Треугольник равнобедренный')
  else
    writeln('Треугольник не равнобедренный');
end;

(2.4k баллов)
0

На самом деле равносторонний треугольник - тоже равнобедренный (это частный случай равнобедренного треугольника), поэтому условие проверки проще.