Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам...

0 голосов
57 просмотров

Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность


Информатика (71 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Program E4; 
  var a, b, с: real; 
begin
  writeln ('введите длины трех сторон треугольника ');
  readln (a, b, с);
  write ('треугольник со сторонами ', а, Ь, с);
  if (а + b > с) and (b + с > a) and (а + с > Ь) then
begin
     writeln ('существует');
     if (a = b) and (a = c) then
     
writeln ('равносторонний')
     else
     writeln ('неравносторонний');
  else 
     writeln ('не существует');
end;
  readln 
end.

(398 баллов)
0

спасибо большое!