Помогите с информатикой. Напишите программу, вычисляющую значение функции!!!

0 голосов
18 просмотров

Помогите с информатикой. Напишите программу, вычисляющую значение функции!!!


image

Информатика (131 баллов) | 18 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  x: real;
  n: integer;

begin
  Write('Введите любое число: ');Readln(x);
  if x < 0 then n := -1
  else
  if x = 0 then n := 0 else n := 1;
  Writeln('y=', n)
end.

Тестовое решение:
Введите любое число: 5
y=1


(142k баллов)
0 голосов

Var x, y: integer;
begin
write('Введите x: ');
readln(x);
if x < 0 then begin y := -1; writeln('y = ', y); end;
if x = 0 then begin y := 0; writeln('y = ', y); end;
if x > 0 then begin y := 1; writeln('y = ', y); end;

end.

(2.3k баллов)