Программа в с++ 1. Описать класс с именем MARSH, содержащую следующие, поля: • BEGST —...

0 голосов
130 просмотров

Программа в с++
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.


Информатика (20 баллов) | 130 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

/*
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/

#include
using namespace std;

class MARSH
{
public:
string BEGST, TERM, NUMER;

MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}

MARSH() {}

void info() {
cout << "Маршрут №" << NUMER<br> << " (" << BEGST << '-'<br> << TERM << ')';<br> }
};

int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;<br> cout << "Название начального пункта маршрута: ";<br> cin >> b;
cout << "Название конечного пункта маршрута: ";<br> cin >> t;
cout << "Номер маршрута: ";<br> cin >> n;
cout << endl;<br> TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";<br> cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;<br> return 1;
}

(7.2k баллов)