Написать программу поиска любого элемента в массиве. Для уточнения - ** языке...

0 голосов
94 просмотров

Написать программу поиска любого элемента в массиве.
Для уточнения - на языке программирования, для программы Паскаль.


Информатика (84 баллов) | 94 просмотров
Дано ответов: 2
0 голосов

Program pm;
uses crt;
var X:array[1..1000] of integer; k,a,b,i:integer;
begin
clrscr;
write('Введите кол-во элементов массива: ');
read(k);
writeln;
write('Введите диапазон значений заполнения(A-начальное значение, B-конечное): ');
repeat
read(a,b);
until a<=b;<br>writeln;
randomize;
for i:=1 to k do X[i]:=random(b-a+1)+a;
writeln('Ваш массив:');
for i:=1 to k do write(X[i]:5);
writeln;
write('Введите элемент поиска: ');
read(b);
a:=0;
for i:=1 to k do if X[i]=b then a:=i;
if a>0 then writeln('Элемент со значением ',b,' имеет индекс ',a)
else writeln('Элемента не существует!');
readkey;
end.

(94 баллов)
0 голосов

Поиска индекса элемента по заданному значению или поиска значения по заданному индексу? Напишу решение для обоих случаев.
1.
Поиск элемента по заданному индексу
var
n:longint;
m:array[1..1000] of longint;
begin
writeln('Введите индекс элемента массива');
read(n);
writeln('Элемент под номером ',n,' равен ',m[n]);
end.

2. Поиск индекса по заданному значению в неупорядоченном массиве:
var
n,i:longint;
m:array[1..1000] of longint;
begin
read(n);
i:=1;
while m[i]<>n do
i:=i+1;
writeln(m[i]);
end.

(1.1k баллов)