По заданной блок-схеме составьте программу на языке Паскаля.
Program n1; var x,y: real; begin readln(x); if x<0 then y:=-x else begin<br>if x<1 then y:=x else begin<br>if x<=2 then y:=1 else y:=-x+3;<br>end; end; write(y); end.
Можно спросить?Заранее прошу прощения за столь может глупый вопрос,но объесните мне пожалуйста,почему 2 раза end повторяется перед окончанием саой программы?