Помогите пожалуйста!!!!!! Написать программу ** языке с#:Дана точка ** плоскости с...

0 голосов
96 просмотров

Помогите пожалуйста!!!!!! Написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу, которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от того, лежит ли точка внутри заштрихованной области, вне заштрихованной области или на ее границе.


image

Информатика (50 баллов) | 96 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main()
{
    float x,y,rxy;
    cin>>x>>y;
    rxy=x*x+y*y;
    if ((rxy>100) || (rxy<25)) cout<<"Нет"<<endl;<br>    else if ((rxy==100) || (rxy==25)) cout<<"На границе"<<endl;<br>    else cout<<"Да"<<endl;<br>    system("pause");
}

C# вот код:
using System;
class Program
{
    static void Main()
    {
        double x=Convert.ToDouble(Console.ReadLine());
        double y=Convert.ToDouble(Console.ReadLine());
        double rxy=x*x+y*y;
        if ((rxy>100) | (rxy<25)) Console.WriteLine("Нет");<br>        else if ((rxy==100) | (rxy==25)) Console.WriteLine("На границе");
        else Console.WriteLine("Да");
        Console.ReadLine();
    }
}

(142k баллов)
0

Неправ... не заметил, что Си шарп, показалось, что С++