Программирование ** C++ Входные данные Вводятся целые числа a и b. Гарантируется, что a...

0 голосов
151 просмотров

Программирование на C++
Входные данные
Вводятся целые числа a и b. Гарантируется, что a не превосходит b. Выходные данные
Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Если таких чисел нет, то ничего выводить не нужно.


Информатика (35 баллов) | 151 просмотров
Дан 1 ответ
0 голосов

#include
#include
int main() {
int a, b;
std::cin >> a >> b;
for (int i = floor(sqrt(a)); i * i <= b; ++i) {<br>std::cout << i * i << " ";<br>}
return 0;
}

(13.3k баллов)