Составить программу в Pascal ABC ,которая из заданной строки получала бы новую строку...

0 голосов
40 просмотров

Составить программу в Pascal ABC ,которая из заданной строки получала бы новую строку ,удалив все "#" и повторив каждый символ ,отличный от знака решотка дважды. Вывести на экран ,полученную новую строку.


Информатика (64 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a:string;
i,j:integer;
begin
readln(a);
while pos('#',a)<>0 do delete(a,pos('#',a),1);

for i:=1 to length(a) do
for j:=1 to 2 do
write(a[i]);
end.

(9.9k баллов)