Написать программу вычисления стоимости покупки с учетом скидки 3% сумма больше 200 рублей

0 голосов
125 просмотров

Написать программу вычисления стоимости покупки с учетом скидки 3% сумма больше 200 рублей


Информатика (12 баллов) | 125 просмотров
Дано ответов: 2
0 голосов

Для PascalABC:

program Project1;
var i:real;
begin
write('Введите стоимость товара ---> ');
readln(i);
writeln('С учётом скидки товар будет стоить ', i*0,03, ' рублей');
end.

Для Delphi:

var i:real;
begin
write('Vvedite stoimost tovara ---> ');
readln(i);
writeln('S ychetom skidki tovar bydet stoit ', i*0,03, ' ryblei');
readln;
end.

Написал два варианта, так как синтаксис и некоторые моменты немного отличаются с использованием Delphi и PascalABC.

(969 баллов)
0

ой, извините, небольшая ошибка: там где "i*0,03" замените на "i-(i*0,03)"

0 голосов

Наверное, имелось ввиду, что скидка будет, если сумма более 200 рублей?

var x: integer;
begin
  write('Введите цену: '); read(x);
  if(x > 200) then writeln('Скидка 3%! Стоимость покупки:', (x * 0.97))
  else writeln('Скидки нет! Стоимость покупки: ', x);
end.

(1.1k баллов)