Составьте программу, выводящую ** экран числа от 1 до 10, а также их квадраты и кубы...

0 голосов
182 просмотров

Составьте программу, выводящую на экран числа от 1 до 10, а также их квадраты и кубы следующим образом:
1 1 1
2 4 8
3 9 27
----------------
10 100 1000


Информатика (16 баллов) | 182 просмотров
Дан 1 ответ
0 голосов

Зависит от того, в чем работаете(Паскаль, С). Как самый просто вариант в паскале("в лоб"):
uses crt
var i:integer; 
begin
i:=1; {присваиваем 1}
repeat
 writeln(); {пустая строка}
 write(i); {пишем само число i}
 write(' '); {ставим пробел}
 write(exp(2*ln(i)):2:0);   {считаем квадрат числа i}
 write(' '); {пробел}
 write(exp(3*ln(i)):2:0); {считаем куб числа i}
 i:=i+1; {новое значение i}
until i>10; {условие окончания i>10}
readkey; {закрытие по нажатию программы}
end.

(138 баллов)