Составьте программу,выводящую ** экран числа от 1 до 30, которые делятся без остатка ** 2...

0 голосов
81 просмотров

Составьте программу,выводящую на экран числа от 1 до 30, которые делятся без остатка на 2 и 3,но не делятся на 4


Информатика (25 баллов) | 81 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var i:integer;
a:array[1..30] of integer;
begin
for i:=1 to 30 do begin
readln(a[i]);
if(a[i]mod 2 =0)and(a[i]mod 3 =0)and (a[i]mod 4 <>0)then writeln(a[i]);
end;end.

(803 баллов)
0

ты уж извини но можеш попроще немножко ато както палевно

0

что значит [i]

0

параметр цикла, индекс массива попроще можно написать 30 одинаковых строк типа if(a[1]mod 2 =0)and(a[1]mod 3 =0)and (a[1]mod 4 <>0)then writeln(a[1]);
if(a[2]mod 2 =0)and(a[2]mod 3 =0)and (a[2]mod 4 <>0)then writeln(a[2]); и так далее

0

но мы массив не проходили(8класс)

0

ой стоп, не так прочитала условие, сейчас исправлю

0

такой вопрос, циклы проходили?

0

да

0

вот тогда
var i:integer;
begin
for i:=1 to 30 do begin
if(i mod 2 =0)and(i mod 3 =0)and (i mod 4 <>0)then writeln(i);
end;
end.

0

спасибо

0

пожалуйста