Напишите программу вычисления выражения: s=1!+2!+3!+...+n! 5-9 класс Здесь n! - факториал...

0 голосов
114 просмотров

Напишите программу вычисления выражения: s=1!+2!+3!+...+n! 5-9 класс
Здесь n! - факториал числа n. n!=1*2*...*(n-1)*n.
Используйте функцию вычисления факториала.


Информатика (15 баллов) | 114 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var f: integer->real:=x->range(1,x).Aggregate(Real(1),(a,b)->a*b);
var n:=ReadInteger('n=');
write(range(1,n).Select(x->f(x)).Sum)
end.

(149k баллов)
0 голосов

Var s,j,k:longint;
function f(n:byte):longint;
var f1:longint;
i:integer;
begin
if n<1 then f1:=1<br>else begin
f1:=1;
for i:=1 to n do
f1:=f1*i;
end;
f:=f1;
end;
begin
s:=0;
readln(k);
for j:=1 to k do
s:=s+f(j);
writeln(s);
readln;
end.

(14 баллов)
0

Можно по легче для 9 класса мы такие команды не учили просто еще