Написать программу в ПАСКАЛЕ: опишите множество Pr(1..20) и поместите в него все простые...

0 голосов
41 просмотров

Написать программу в ПАСКАЛЕ: опишите множество Pr(1..20) и поместите в него все простые числа в диапозоне 1..20. В цикле организуйте ввод чисел в диапозоне 1..20 и определите, простые они или нет . Выход из цикла - введеное значение , равное 99.


Информатика (37 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  Pr: set of 1..20;
  x: integer;

begin
  Pr := [1, 2, 3, 5, 7, 11, 13, 17, 19];
  writeln('Вводите целые числа от 1 до 20, выход по 99');
  repeat
    write('Число ');
    readln(x);
    if x < 21 then
      if x in Pr then writeln('простое')
      else writeln('не простое')
  until x = 99
end.

Тестовое решение:

Вводите целые числа от 1 до 20, выход по 99
Число 18
не простое
Число 3
простое
Число 15
не простое
Число 23
Число 19
простое
Число 99



(142k баллов)