Напишите программу,которая получает два целых числа и находит их произведение не...

0 голосов
361 просмотров

Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример :введите два числа: 10-15,10*(-15)=-150


Информатика (15 баллов) | 361 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  a, b, prod, i: integer;
begin
  writeln('Введите два числа: ');
  readln(a, b);
  prod := 0;
  if (b < 0) then
    for i := b to -1 do
      dec(prod, a)
  else
    for i := 1 to b do
      inc(prod, a);
  writeln(prod)
end.

(148k баллов)
0

спасибо большое) а не могли бы составитьблок схему для этой задачи?