Тема массивы, язык паскаль. Составьте программу которая заменяет все числа кратные 9 **...

0 голосов
60 просмотров

Тема массивы, язык паскаль.
Составьте программу которая заменяет все числа кратные 9 на -5(Массив задается с клавиатуры , количество элементов 12)


Информатика (116 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program z1;
var a:array[1..12] of integer;
i:integer;
begin
for i:=1 to 12 do
begin
readln(a[i]);
if a[i] mod 9 =0 then a[i]:=-5;
end;
for i:=1 to 12 do writeln(a[i]);
end.

(1.3k баллов)