Написать программу которая определяет число полиндромПаскаль(ну или хотя бы идейку...

0 голосов
57 просмотров

Написать программу которая определяет число полиндром
Паскаль
(ну или хотя бы идейку подкиньте)


Информатика (48 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Program palindrom;
Uses crt;
var    s: string;
    i,f: byte;
begin 
clrscr;
   write('String: ');
    readln(s);
    f := 0;
    for i := 1 to length(s) div 2 do        if s[i] <> s[length(s)-i+1] then begin            writeln('No palindrome');
            f := 1;
            break       
end;
    if f = 0 then        write('Palindrome');
readln
end.

0

Спасибо большое)