Напишите программу в которой осуществляется ввод целых чисел и подсчет суммы и среднего...

0 голосов
166 просмотров

Напишите программу в которой осуществляется ввод целых чисел и подсчет суммы и среднего арифметического введенных положительных чисел используя оператор repeat


Информатика (12 баллов) | 166 просмотров
Дан 1 ответ
0 голосов
Pascal:
var
   i,sum:integer;
   sr:real;
   a:array[1..10] of integer;
begin
   writeln('Введите 10 чисел');
   for i:=1 to 10 do
       read(a[i]);
repeat
     if a[i]>0 then
       begin
          sum:=sum+a[i];
          p:=p+1;
       end;
until i:=10;
sr:=sum/p;

writeln('Сумма = ',sum,'Среднее арифмитический = ',sr);

end.
(208 баллов)