Уважаемые знатоки информатики! По информатике задали составить программу в pascal:...

0 голосов
61 просмотров

Уважаемые знатоки информатики! По информатике задали составить программу в pascal: сколько дней осталось до данного числа (26.10.14)? Нужно, чтобы она высчитывала это кол-во дней.


Информатика (91 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Для текущего месяца (т.е. только для октября, потому что не было указано в вопросе учитываются другие месяцы или нет)
program zd;
const
b=26;
var
a,c:byte;
begin
writeln('Введите день');
readln(a);
if ac:=b-a
else {иначе вывести смс}
writeln('Данный день уже прошёл');
writeln('Осталось', с, 'дней');
end.

Вроде бы правильно) извиняюсь за исправления, просто тороплюсь

(449 баллов)
0

Огромное вам спасибо! А то в информатике я чайник, а сейчас, вроде бы, разобралась. Мне вот интересно, а если для всех месяцев, тогда как? Не могли бы помочь?

0

можно, наверное, просто добавить строчку
"writeln ('Введите месяц')"

0

сейчас напишу

0

Можно было бы реализовать так:
program zd;
const
b=26; d=10;
var
a,t,c:byte;
begin
writeln('Введите день');
readln(a);
writeln('Введите месяц');
readln(t);

0

if t<=d then {если месяц меньше указанного то проверить дальше условие}<br>if ac:=b-a;
y:=d-t;
end
else {иначе вывести смс}
writeln('Данный день и месяц уже прошёл');
writeln('Осталось', с, 'дней');
writeln('Месяцев осталось',y);
end.

Сомневаюсь, что работает/ работает правильно, но примерно так будет

0

Да-да работает! огромное вам спасибо!

0

Пожалуйста)