Информатика 9 класс. Составить программу нахождения средней буквы в слове. В Паскале.

0 голосов
106 просмотров

Информатика 9 класс. Составить программу нахождения средней буквы в слове. В Паскале.


Информатика (19 баллов) | 106 просмотров
0

А если слово состоит из четного количества букв, какая из них будет средней?

0

Программа не выдаст среднюю букву.

Дан 1 ответ
0 голосов
Правильный ответ

var

 Word: string;

 i: Integer;

begin

 Write ('Введите слово: ');

 Read (Word);

 if (Length (Word) mod 2) <> 0 then begin         // проверка на нечетность количества букв

   i := (Length (Word) div 2) + 1;              // i = индекс средней буквы

   WriteLn ('Средняя буква = "', Word [i], '"');

 end else begin

   WriteLn ('Слово состоит из четного количества букв');

 end;

end.

(6.4k баллов)