Написать программу, которая проверяет – имеется ли в записи натурального числа ноль. Язык...

0 голосов
53 просмотров

Написать программу, которая проверяет – имеется ли в записи натурального числа ноль.
Язык программирования паскаль.


Информатика (18 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

Program red;
var a,b,c:integer;
begin
b:=0;
readln(a);
if a<10 then<br>begin
if a*5=0 then b:=1;
end;
if (a>=10) and (a<100) then<br>begin
if ((a div 10)*5=0) then b:=1;
if ((a mod 10)*5=0) then b:=1;
end;
if (a>=100) and (a<1000) then<br>begin
if ((a div 100)*5=0) then b:=1;
if (((a div 10) mod 10)*5=0)then b:=1;
if ((a mod 10)*5=0)then b:=1;
end;
if b=1 then writeln('yes') else writeln('no');
end.

(648 баллов)