Поставлю лучший, много баллов! Напишите программу в Pascal ABC которая ввод данных в...

0 голосов
44 просмотров

Поставлю лучший, много баллов! Напишите программу в Pascal ABC которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод - REPEAT...UNTIL (в скобках указана размерность массива):
увеличить элементы массива с четными индексами на 1 (11)


Информатика (1.0k баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:array[1..11] of integer;
b:integer;
begin
b:=1;
writeln('Введите элементы массива');
while (b<=11) do<br>begin
readln(a[b]);
if (b mod 2=0) then a[b]:=a[b]+1;
b:=b+1;
end;
b:=1;
repeat
writeln(a[b]);
b:=b+1;
until(b>11)
end.

(13.4k баллов)
0

Будте добры: http://znanija.com/task/6469863