Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых...

0 голосов
52 просмотров

Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел(Определенного типа) к переполнению.


Информатика (35 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  low=-32768;
  high=32767;
Var i, j :integer;
begin
  readln(i,j);
  if sign(i)*sign(j)<0 then writeln('Сложение допустимо, результат ',i+j)<br>  else
    if i<0 then<br>      if j      else writeln('Сложение допустимо, результат ',i+j)
    else
      if j>high-i then writeln('Сложение недопустимо: возникнет переполнение')
      else writeln('Сложение допустимо, результат ',i+j)
end.

(142k баллов)