Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа...

0 голосов
123 просмотров

Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа замените квадратами,если а>b>c,то каждое число замените наибольшим из них,в противном случае смените знак каждого числа. С2.По номеру месяца выдайте квартал,которому он принадлежит.


Информатика (367 баллов) | 123 просмотров
Дан 1 ответ
0 голосов

Var a,b,c:integer;
begin
readln(a,b,c);
if (a<=b) and (b<=c) then<br>begin
a:=a*a;
b:=b*b;
c:=c*c;
end
else if (a>b) and (b>c) then
begin
if aif ab:=a; c:=a;
end 
else     
begin       
a:=a*(-1);       
b:=b*(-1);       
c:=c*(-1)     
end; 
writeln(a:4, b:4, c:4);
end.

(57 баллов)
0

var a,b,c:integer;
begin
readln(a);
if (a>=1)and (a<=3) then writeln('1 квартал');<br>if (a>=4)and (a<=6) then writeln('2 квартал');<br>if (a>=7)and (a<=9) then writeln('3 квартал');<br>if (a>=10)and (a<=12) then writeln('4 квартал');<br>end.