Напишите программу в паскале, которая вводит два целых числа и находит их произведение,...

0 голосов
86 просмотров

Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения.Учтите, что числа могут быть отрицательными.


Информатика (128 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Var x,y,p,i:integer;
begin
readln(x,y);
for i:=1 to abs(y) do  p:=p+x;
if y<0 then p:=-p;<br>writeln(p);
end.