1)Составить программу которая выводит ** экран каждое 5-ое число и таких чисел...

0 голосов
29 просмотров

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.
2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.


Информатика (24 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
1.

var
i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(21)-10;
 for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Каждый пятый эелемент массива: ');
 for i:=1 to 20 do if i mod 5 = 0 then write(A[i]:5);
end.

2.
var
x,i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
 for i:=1 to 20 do A[i]:=random(11);for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Натуральные числа в диапазоне [5..10]: ');
 for i:=5 to 10 do write(A[i]:5);
writeln;
x:=1;
writeln('Их произведение: ');
 for i:=5 to 10 do x:=A[i]*x;
write(x:5); 
end.
(1.4k баллов)