Напишите программу, в которой даны три действительных числа. Возвести в квадрат...

0 голосов
130 просмотров

Напишите программу, в которой даны три действительных числа. Возвести в квадрат положительные числа и в четвертую степень - отрицательные c#


Информатика (12 баллов) | 130 просмотров
Дан 1 ответ
0 голосов

Ответ:

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

(2.5k баллов)