Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет среднее арифметическое элементов этого массива.
Ответ:
#include
using namespace std;
int main()
{
int n[10],a,b;
float s;
cout<<"OT: ";cin>>a;
cout<<"DO: ";cin>>b;
srand(time(0));
for (int i = 0; i
n[i] = a+rand()%b;
}
cout <<"Все числа: ";</p>
for (int i = 0;i
cout<<" "<<n[i];</p>
s = s + n[i];
cout<<endl<<"ITOG: "<<s/(sizeof(n)/sizeof(int));</p>
return 0;
Объяснение: