1. Написать программу, которая формирует случайным образом массив из N целых чисел,...

0 голосов
118 просмотров

1. Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом. Протестировать программу на трёх различных тестах. 2. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. 3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количе-ство замен. Мы не изучали константы, поэтому можно обойтись без них?


Информатика (36 баллов) | 118 просмотров
0

а причем здесь константы?)

Дан 1 ответ
0 голосов

1)

#include

#include

#include

#include

#include

using namespace std;

signed main() {

   srand(time(NULL));

   int n;

   cin >> n;

   int a[n];

   for(int i = 0; i < n; i++)

       a[i] = rand() % 5 + 1;

  vector ans;

   for(int i = 0; i < n; i++)

   {

       cout << a[i] << " ";</strong>

       if(a[i] == a[0])

           ans.push_back(i);

   }

   cout << "\n";</strong>

   for(auto i: ans)

       cout << i << " ";</strong>

}

2)

#include

#include

#include

#include

#include

using namespace std;

signed main() {

   int n,k;

   cin >> n >> k;

   int a[n];

   vector ans;

   for(int i = 0; i < n; i++)

   {

       cin >> a[i];

       if(a[i] % k == 0)

           ans.push_back(a[i]);

   }

   for(auto i: ans)

       cout << i << " ";</em>

}

3)

#include

#include

#include

#include

#include

using namespace std;

signed main() {

   int n,z;

   cin >> n >> z;

   int a[n];

   for(int i = 0; i < n; i++)

   {

       cin >> a[i];

       a[i] = min(a[i],z);

   }

   for(auto i: a)

       cout << i << " ";</strong>

}

(688 баллов)