Составить программу в Паскаль.Очень нужна ваша помощь

0 голосов
29 просмотров

Составить программу в Паскаль.Очень нужна ваша помощь


image

Информатика (146 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Ответ:

pascal

Объяснение:

const

 s: string[8] = '01234567';

var

 d, n: integer;

 o: string;

begin

 Write('Введите число: ');

 ReadLn(n);

 d := n;

 while d > 0 do

 begin

   o := s[d mod 8+1] + o;  

   d := d div 8;

 end;  

 WriteLn(n, '(10) = ', o,'(8)');

end.


image
(1.0k баллов)
0

Перепроверьте,пожалуйста

0

только что... все нормально работает

0

прям отсюда скопировал и запустил. все ок

0

Я тоже отсюда скопировала

0

Program2.pas(3) : Неожиданный символ ' '

0

тогда другой вариант

0

Вы исправите?

0

что-то текст не дает вставить. картинку прикрепил

0

Спасио

0

Спасибо