** питоне. Напишите программу, выводящую ** экран изображение шахматной доски, где черные...

0 голосов
613 просмотров

На питоне. Напишите программу, выводящую на экран изображение шахматной доски, где черные клетки изображаются звёздочками, а белые - пробелами. Рекомендуемый вид экрана после выполнения программы:​


image

Информатика (40 баллов) | 613 просмотров
Дан 1 ответ
0 голосов

'''

Python 3

'''

#!/usr/bin/env python

from __future__ import print_function

for i in range(1,9):

   for j in range(1,9):

       if i % 2 == 0:

           if j % 2 == 0:

               print("*", end=' ')

           else:

               print(" ", end=' ')

       else:

           if j % 2 != 0:

               print("*", end=' ')

           else:

               print(" ", end=' ')

   print()

(3.7k баллов)