Написать программу в PascalAbc.net Задано натуральное число .напишите программу ,которая...

0 голосов
85 просмотров

Написать программу в PascalAbc.net Задано натуральное число .напишите программу ,которая для число с нечётным количеством цифр выведет на экран цифру , стоящую на средней позиции числа .


Информатика (36 баллов) | 85 просмотров
Дан 1 ответ
0 голосов

var

 x, a, k, t, i, d: integer;

begin

 readln(x);

 a := x; k := 0;

 while a > 0 do

 begin

   k += 1;

   a := a div 10;

 end;

 if k mod 2 = 0 then

   write('В числе четное количество цифр')

 else

 begin

   t := 1;

   for i:=1 to k div 2 do

     t *= 10;

   d := x div t mod 10;

   write(d);

 end

end.

(476 баллов)
0

Сорян , случайно поставил 1