Напишите программу задачи ** языке Паскаль. Требуется выяснить, является ли введенное...

0 голосов
42 просмотров

Напишите программу задачи на языке Паскаль. Требуется выяснить, является ли введенное пользователем число совершенным. Совершенным называется такое число, сумма делителей которого равна этому числу, если не учитывать в ней последний делитель-само заданное число. Например, число "6" является совершенным числом, поскольку оно имеет три делителя: 1, 2, 3 и при этом 1+2+3=6, то есть самому числу


Информатика (42 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

var N,i,k:integer;

BEGIN

readln(N);

k:=0;

for i:=1 to N div 2 do

if (N mod i=0) then

k:=k+i;

if (k=N) then

writeln('Да') else

writeln('Нет');

end.

(1.4k баллов)