В классе 20 учеников писали диктант по русскому языку Напишите программу в паскале...

0 голосов
75 просмотров

В классе 20 учеников писали диктант по русскому языку Напишите программу в паскале подсчитывающую количество двоек, троек, четвёрок и пятёрок полученных за диктантПожалуйста через рандом и не используя caseЗаранее спасибо ​


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

var

   d : array of integer := new integer[20];

   b : array of integer := new integer[5];

   

begin

   d := arrRandom(20, 1, 5);

   for var i := 0 to 19 do b[d[i]-1] += 1;

   for var i := 1 to 4 do writeln(i+1, ' получили ', b[i], ' учеников');

end.

(1.2k баллов)