1. Написать программу, выводящую ** экран строку "Hello World" 10раз. 11. Написать...

0 голосов
74 просмотров

1. Написать программу, выводящую на экран строку "Hello World" 10раз.
11. Написать программу, которая выводит на экран линию из символов. Число символов, какой использовать символ, и какая будет линия горизонтальная или вертикальная - вводит пользователь.
написать программы на языке с++ в MinGWstudio
p.s: задачи для самых умных людей на планете. кто решит, тот Бог всех Богов.


Информатика (63 баллов) | 74 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

 1.
#include //если не отображается, пиши после include - iostream в <>
 using namespace std;

 int main(){
  for(int i=0;i<10;i++)<br>         cout<<"Hello World";<br>  cin.get();
  cin.get();
  return 0;
 } 11.
#include  //если не отображается, пиши после include - iostream в <>
#include  //если не отображается, пиши после include - string в <>
using namespace std;
int main() {
string s,p;
         cin>>s;
         cin>>p;
         if((p!="v") && (p!="g"))
         return 66;
         int n;
         cin>>n;
         if (p=="g"){
         for(int i=0;i         cout<<s;<br>         }
         else
         {
         for(int i=0;i         cout<<s<<"\n";<br>         }
         cin.get();
         cin.get();
return 0;
}

(38.6k баллов)
0

А как насчет "какой использовать символ, и какая будет линия горизонтальная или вертикальная - вводит пользователь." ?

0

Хмм, раньше здесь этого не было. Сейчас поправлю.

0

Возможно. Но Вы добавили решение уже после того, как было сделано редактирование вопроса... автор вопроса был в своем праве.

0

Библиотеки( по какой-то причине не выводятся

0

1. iostream 2. iostream, string

0

К сожалению, комментарии в вопросах и ответах впоследствии отрезаются, поэтому требуется, что все необходимое было в вопросах и ответах. Я отправлю Вам на исправление ответ и у Вас будет 5 суток на исправление.

0

Только помните, что правку можно внести только один раз - после сохранения правка станет недоступной

0

Спасибо огромное)