Пожалуйста,напишите программу по информатике ,** этот пример Под корнем 5х-1/ х-10

0 голосов
20 просмотров

Пожалуйста,напишите программу по информатике ,на этот пример Под корнем 5х-1/ х-10


Информатика (12 баллов) | 20 просмотров
Дан 1 ответ
0 голосов

Ты не указал язык программирования, но будем надеяться, что язык - си подобный или python.

с++:

#include

#include  // Подключаем корни

using namespace std;

int main ()

{

float x = 0; // Float т.к. может быть введен не целое число

cin >> x;

if (x == 10)

{

cout << "Error, deliver by zero"; </p>

return 0;

//Если x = 10, то в следующей формуле мы                              

//должны будем делить на 0 - это не круто

}

float answ = sqrt ( (5 * x - 1) / (x - 10) )  // - Это формула

cout << answ;</p>

}


c:

#include

int main ()

{

float x = 0; // Float т.к. может быть введен не целое число

scanf ("%lg", &x)

if (x == 10)

{

print ("deliver on zero");

return 0;

//Если x = 10, то в следующей формуле мы                              

//должны будем делить на 0 - это не круто

}

float answ = sqrt ( (5 * x - 1) / (x - 10) )  // - Это формула

print ("%lg", answ);

}

}


Python:

from math import * #подключаем корни и остальную математику

x = float (input ()) # float т.к. может быть введено не целое число

if x == 10:

   print ("deliver on zero") # проверка на то, что мы не делим на ноль

else:

   answ = sqrt ( (5 * x - 1) / (x - 10)

   print (answ) # здесь твоя формула

   print ()

Другой Язык:

К сожалению Паскаль и другие я зыки я плохо знаю, но вот алгоритм:

1. Подключаем математику (если взятие корня не стандартная функция (т.е. ее без подключения просто нет)).

2. Создаем переменную типа данных с плавающей запятой (Если при создание переменных не указывается тип данных, просто создаем переменную)

3. Считываем в нее информацию типа с плавающей запятой (не просто строка)

4 выполняем эту формулу (как правило с помощью умножения  *, деления  /, сложения  +, вычитание -, Скобки (), взятие квадратного корня sqrt (выражение)) и записываем в новую переменную с типом данных с плавающей запятой (Если при создание переменных не указывается тип данных, просто записываем в  переменную)

5  выводим новую переменную.

* Можно сделать пользовательский интерфейс, если эту задачу проверяет не компьютер

** Пиши, если что-то не понятно либо в комменты к вопросу, либо

в ВК ilya180620 (без спама само, собой :) )

(1.4k баллов)
0

блиин как криво он перенес строки