Написать программу.Паскаль.Задан массив BON из N чисел (N=20) случайным образом в...

0 голосов
27 просмотров

Написать программу.Паскаль.Задан массив BON из N чисел (N=20) случайным образом в диапазоне [-5..5]. Найти количество четных элементов массива.


Информатика (18 баллов) | 27 просмотров
0

Да сколько можно вас всех учить. Пишите язык, на котором нужно программировать. Сейчас на ассемблере напишу и посмотрим, как вы его читать будете

0

Pascal

Дан 1 ответ
0 голосов

const N = 20;

var BON:array[0..N] of integer;

   amount: integer;

   i: integer;

begin

 amount := 0;

 randomize;

 for i := 0 to N do

   BON[i] := random(-5,5);

 for i := 0 to N do

   if(BON[i] mod 2 <> 1) then

     amount := amount + 1;

writeln('Четных чисел ',amount);

end.

(3.4k баллов)