Составьте программу, которая формирует массив из 16 случайных целых чисел от -20 до 20, и...

0 голосов
65 просмотров

Составьте программу, которая формирует массив из 16 случайных целых чисел от -20 до 20, и определяет, есть ли в этом массиве числа, равные 0. На экран выводятся исходный массив и индекс последнего найденного элемента. ПАСКАЛЬ


Информатика (12 баллов) | 65 просмотров
Дано ответов: 2
0 голосов

begin

var a := ArrRandomInteger(16, -20, 20);

a.Println;

println(a.LastIndexOf(0));

end.

(64 баллов)
0 голосов

const n=16;

var a:array [1..n] of integer;

i,k:integer;

begin

write('Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write(a[i],'  ');

if a[i] = 0 then k:=i

end;

writeln;

writeln('Индекс последнего найденного элемента: ',k)//или if k <> 0 then writeln('Индекс последнего найденного элемента: ',k) - если выводить индекс только когда есть 0 элементы

end.

(1.7k баллов)