PascalABC.NET Текстовый файл Input.txt содержит натуральные числа. Написать программу, которая создает текстовый файл Output.txt, содержащий все четные числа файла Input.txt в порядке возрастания.
Попробуй этот код
uses crt;
var f,g:text;
a,max,min:integer;
begin
assign(f,'C:\in.txt');
assign(g,'C:\out.txt');
reset(f);
rewrite(g);
max:=0;
min:=0;
while not eof(f) do
read(f,a);
if a>max then max:=a;
if a
end;
writeln(g,'max ',max);
writeln(g,'min ',min);
close(f);
close(g);
end.
пример Input.txt ()
пример Input.txt (2;1;7;3;-1;8) Output.txt (2;8)