Напишите программу : винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, В каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших дня. За сколько дней он съест К грамм варенья? Паскаль 10 класс
Var k,k1,k2,kn,n,s:integer; begin write('k = '); readln(k); k1:=100; k2:=100; s:=k1+k2; if k<=k1 then n:=1 else n:=2;<br>while s begin n:=n+1; kn:=k1+k2; s:=s+kn; k1:=k2; k2:=kn; end; writeln('n = ',n); end. Пример: k = 1100 n = 5
если я возьму 800 то винипух должен съесть за 6 дней
а тут получается не так
моя ошибка понял