Информатика,Паскаль,написать программу: Сформировать массив, состоящий из n целых...

0 голосов
38 просмотров

Информатика,Паскаль,написать программу: Сформировать массив, состоящий из n целых элементов, лежащих в промежутке [10;10] Вычислить:
-минимальный по модулю элемент
- количество элементов кратных 5
- сумму элементов массива, расположенных между первым и последним положительными элементами.


Информатика (22 баллов) | 38 просмотров
0

В промежутке [10;10] лежит только 10. Если речь о [-10;10] - исправьте.

0

ага,[-10;10]. Не знаю как исправить

Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  Writeln('Минимальный по модулю элемент равен ',
      a.Select(t->Abs(t)).Min);
  Writeln('Количество элементов, кратных 5, равно ',
      a.Where(t->t mod 5=0).Count);
  Write('Сумма искомых элементов равна ');
  var ai:=a.Indexesof(t->t>0);
  a[ai.First+1:ai.Last].Sum.Println;
end.

image
(150k баллов)