Помогите написать программу (информатика) 9 класс. ХРИСТА РАДИ ПОМОГИТЕ ЛЮДИ ДОБРЫЕ!! -...

0 голосов
47 просмотров

Помогите написать программу (информатика) 9 класс.
ХРИСТА РАДИ ПОМОГИТЕ ЛЮДИ ДОБРЫЕ!!
-
1. Найти площадь закрашенной фигуры, если известна сторона квадрата и радиус круга.


Информатика (508 баллов) | 47 просмотров
0

Рисунок: квадрат и в нём круг

0

А можно рисунок к вопросу приложить?

Дан 1 ответ
0 голосов

Площадь круга pi*r*r
Площадь квадрата a*a

Искомая площадь, если я правильно себе представил рисунок, равна a*a - pi*r*r.

begin
  var a, r: real;
 
  readln(a);
  readln(r);
 
  writeln(a*a - pi*r*r);
end.

(9.2k баллов)