Помогите пожалуйста по информатике составить программу в паскале.Создать одномерный...

0 голосов
23 просмотров

Помогите пожалуйста по информатике составить программу в паскале.Создать одномерный массив А из 10 целых чисел (с помощью рандома в диапазоне (-50;100). Посчитать количество отрицательных и неотрицательных элементов массива.


Информатика (15 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.3
begin
  var a:=ArrRandom(10,-50,100); a.Println;
  var k:=a.Where(x->x<0).Count;<br>  writeln('Количество отрицательных = ',k,
          ', количество неотрицательных = ',10-k);
end.

Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7

(194k баллов)